Simpler Plugins Blog

Updates about the “Simpler” plugins for WordPress

Archive for June 2009

Simpler iPaper 1.3

leave a comment »

In this version, I’ve resolved the issue on some installs of WordPress where a correctly formatted shortcode (using [ scribd ] on its own, as opposed to [ scribd ]...[/ scribd ]) results in a warning message. The behaviour is unnecessary and has been removed.

Now, [ scribd ]...[/ scribd ] too should work properly.

Download version 1.3 of Simpler iPaper

Note: references to the ‘scribd’ shortcode in this post were modified with added spaces in order to prevent WordPress from changing them into embeds.

Advertisements

Written by Frederick

June 25, 2009 at 3:43 pm

Posted in Simpler iPaper

Tagged with

Simpler CSS 0.3

leave a comment »

In Version 0.3, no significant code changes were made, but the plugin’s metadata has been edited to reflect its compatibility with up to WordPress 2.9-rare (trunk version).

Download version 0.3 of Simpler CSS

Written by Frederick

June 25, 2009 at 3:39 pm

Posted in Simpler CSS

Tagged with

Changelogs on the Plugin Directory

leave a comment »

I got word that the WordPress plugin directory now supports changelogs. This is great news for users, since they can now know what’s different in the new releases, right on the plugin directory site or even in their WordPress admin areas.

Changelog tab on the directory, via westi on wordpress

Changelog tab on the directory, via westi on wordpress

When I release the upcoming updates of Simpler CSS and Simpler iPaper, I will be sure to incorporate a changelog into the readme, but I will not be adding the changes from releases earlier than Simpler iPaper 1.1 and Simpler CSS 0.2b.

Written by Frederick

June 20, 2009 at 10:17 am

Posted in News

Tagged with , , , ,

Updates for WordPress 2.8

leave a comment »

Not too long ago, WordPress 2.8 was released.

Although the Simpler CSS and Simpler iPaper plugins have not been updated for WordPress 2.8, there are no changes in WordPress that would likely affect the proper functioning of the plugins.

In any case, updated versions will be released within the week. However, I am debating whether to update it to Tested up to: 2.8 or Tested up to: 2.9-rare, which is the version string used in the Subversion trunk as of June 18. We’ll see.

Addendum: Simpler iPaper will still be compatible with older versions as it moves forward. Simpler CSS will still be compatible with only 2.7 and up.

Written by Frederick

June 18, 2009 at 7:24 pm

Posted in Simpler Development

Tagged with ,